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Chapter 1 
Introduction 

Using this Manual 
This manual introduces you to SAP2000 Version 19. The step-by-step instruc-
tions guide you through development of your first model. The intent is to 
demonstrate the fundamentals and to show how quickly and easily a model can 
be created using the program. Completing the tutorial will give you hands-on 
experience working with SAP2000, which for most people is the quickest way 
to become familiar with the program. 

If you are viewing this manual as a .pdf file, we strongly recommend that you 
print it before starting the tutorial. It will not be practical to use the SAP2000 
program while trying to read this manual on your computer screen. 

Overview of the Program 
SAP2000 is a stand-alone finite-element-based structural program for the anal-
ysis and design of civil structures. It offers an intuitive, yet powerful user inter-
face with many tools to aid in the quick and accurate construction of models, 
along with the sophisticated analytical techniques needed to do the most com-
plex projects. 
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SAP2000 is object based, meaning that the models are created using members 
that represent the physical reality. A beam with multiple members framing into 
it is created as a single object, just as it exists in the real world, and the mesh-
ing needed to ensure that connectivity exists with the other members is handled 
internally by the program.  Results for analysis and design are reported for the 
overall object, and not for each sub-element that makes up the object, provid-
ing information that is both easier to interpret and more consistent with the 
physical structure. 

Overview of the Tutorial 
SAP2000 is an extremely versatile and powerful program, with many features 
and functions. This tutorial does not attempt to cover all of those capabilities. 
Rather, we briefly show how to work with the program, providing some com-
mentary along the way. To more fully grasp the value of SAP2000, use this in-
troductory tutorial in conjunction with the SAP2000 documentation, including 
the Verification manual. 

We recommend that you perform each step of the tutorial as you read the man-
ual. Therefore, the program should be installed on your computer before you 
begin. Prepare to spend at least one hour going through the example.  If at any 
time you need to stop, save your model so that you may continue at a later 
time. 

During the course of the tutorial, we will explore many of the basic features of 
SAP2000. We hope that you enjoy and find this approach helpful as a starting 
point in your use of this powerful and comprehensive version of SAP2000. 

Welcome to SAP2000. 
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Chapter 2 
An Introductory Tutorial  

This chapter provides step-by-step instructions for building a basic 
SAP2000 model. Each step of the model creation process is identified, 
and various model construction techniques are introduced. At the com-
pletion of this chapter, you will have built the model shown in Figure 1.  

 

Figure 1 
The Tutorial 
Model 
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The Project 
The tutorial project is a 1-bay by 3-bay industrial building. The open bay 
has a dimension of 36 feet, while the three bays in the longitudinal direc-
tion are each 12 feet wide. The concrete roof is supported by trusses in 
the transverse direction, which frame into tube columns pinned at the 
base. 

The trusses are to be constructed of W shapes, while the roof will be a 
concrete slab 5 inches thick. The columns are HSS 8x8x3/8 sections. The 
building will be analyzed for static loads only, and the trusses will be 
loaded at their panel points with a Dead Load = 20 kips, while the roof 
will be loaded with a Live Load = 30 pounds per square foot (psf) and a 
Wind Load = 15 psf on the windward side and 6 psf on the leeward side. 

The Interface  
The top menu line contains all of the commands and options available to 
SAP2000, including Define, Draw, Select, Assign, Analyze, Display and 
Design. In addition to these menus, many of the most frequently used 
commands are accessible as a single click button in the screen regions 
surrounding the drawing areas. The availability of a button is indicated in 
the main menus by the existence of an icon to the left of the command.  
The lower right corner shows the current unit selection. Figure 2 shows 
the layout of the interface. 

 

Main Menu Bar 

Units 

Main Menu Bar

Units

Figure 2 
The Interface 
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Step 1    Begin a New Model 
In this Step, the basic grid that will serve as a template for developing the 
model will be defined. Then a material will be defined and sections will 
be selected, including a list of W sections for the truss Auto Select Sec-
tion list.  

A. Click the File menu > New Model command or the New Model but-
ton      . The form shown in Figure 3 will display.  Verify that the de-
fault units are set to lb-ft. 

 
 
 
 
 
 
 
 
Figure 3 
New 
Model 
form 

 

 

 

 

 

 

 

B. The New Model form allows for the quick generation of numerous 
model types using parametric generation techniques. However, in 
this tutorial the model will be started using only the grid generation.  
When laying out the grid, it is important that the geometry defined 
accurately represents the major geometrical aspects of the model, so 
it is advisable to spend time carefully planning the number and spac-
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ing of the grid lines.  Select the Grid Only button, and the form 
shown in Figure 4 will display.  

 

C. The Quick Grid Lines form is used to specify the grids and spacing 
in the X, Y, and Z directions. Set the number of grid lines to 2 for the 
X direction, to 7 for the Y direction, and to 3 for the Z direction. 
Type 432 in (including the in) into the X direction spacing edit box 
and press the Enter key on your keyboard. Note that the program au-
tomatically converts the 432 in to 36 to be consistent with the default 
units of feet. Enter 6 for the Y direction spacing, and 20 for the Z di-
rection spacing. The values specified in the First Grid Line Location 
area locate the origin of the grid lines; make sure that these values 
are all set to zero for this tutorial. 

Figure 4 
Quick Grid Lines 
form 
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Figure 5 
The SAP2000 windows 
 

D. Click the OK button to accept the changes, and the program will appear 
as shown in Figure 5. Note that the grids appear in two view windows 
tiled vertically, an X-Y Plane View on the left and a 3-D View on the 
right. The number of view windows may be changed using the drop-
down arrow located in the top right corner of each window. 

The “Plan” view is active in Figure 5. When the window is active, the 
display title bar is highlighted.  Set a view active by clicking anywhere in 
the view window. If you are unable to see the grid bubbles in this view, 
click the View menu > Zoom Out One Step command until they be-
come visible.  

Note that the Global Axes are displayed as well, and that the Z positive is 
in the “up” direction. When SAP2000 refers to the direction of gravity, 
this is in the negative Z direction, or “down.” 

E. Click the Define menu > Coordinate Systems/Grids command to dis-
play the Coordinate/Grid Systems form. In the Systems area, highlight 
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GLOBAL and then click the Modify/Show System button to display the 
Define Grid System Data form shown in Figure 6. 

 
 
 
 
 
 
 
 

Figure 6 
Define 
Grid 
System 
Data 
form 

 

 

 

 

 

F. The Define Grid System Data form is used to modify the grid layout. 
Under the Z Grid Data area, type 24 into the Ordinate edit box for 
Grid ID Z3 and press the Enter key on your keyboard. 

G. Click the OK button twice and a modified grid will now be dis-
played. 

Define a Material 
Two default material properties are predefined; one for concrete and one 
for steel. A third material property will be added for the HSS columns. 
Varying levels of sophistication may be used to define the materials, in-
cluding inputting advanced nonlinear stress-strain curve data. For this tu-
torial, an additional material will be added using a predefined property. 
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A. Click the Define menu > Materials command to display the Define 
Materials form shown in Figure 7. 

 

 

 

Figure 7 
Define Mate-
rials form 

 

 

 

B. Click the Add New Material button to display the Add Material 
Property form shown in Figure 8. 

C. The Add Material Property form allows for the rapid selection of ma-
terial types from predefined standards. Select Steel from the Material 
Type drop-down list.  

 

Figure 8 
Add Material Proper-
ty  
form 

 

 

 

D. Select ASTM A500 from the Standard drop-down list and Grade B, 
Fy 46 (HSS Rect.) from the Grade drop-down list; the program has 
all of the properties needed for this material type already defined. 
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E. Click the OK buttons to close the Add Material Property and Define 
Materials forms. 

Define Frame Sections  
A frame section will be defined for the HSS columns. Frame sections 
must be defined before they can be assigned to frame objects in the mod-
el. 

A. Click the Define menu >  Section Properties > Frame Sections 
command, which will display the Frame Properties form shown in 
Figure 9.  

 

 

 

Figure 9 
Frame  
Properties  
form 

 

 
 

B. Click the Import New Property button, which will display the Im-
port Frame Section Property form shown in Figure 10.  
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Figure 10 
Import 
Frame 
Section  
Property 
form 

 

 

 

 
 

 

C. Verify that Steel is showing in the Frame Section Property Type 
drop-down list, and then in the Click to Import a Steel Section area 
of the Import Frame Section Property form, click the Tube button, 
which will open the Section Property File form. 

D. Use the Section Property File form to locate the SECTIONS8.PRO 
file, which contains the properties of the HSS section to be used in 
the model. The SECTIONS8.PRO file likely will be stored with the 
program files for SAP2000. Highlight the file name and click the 
Open button. The Sections8.pro sections list form shown in Figure 
11 displays.  
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Figure 11 
Sections8.pro 
sections  
list 
 

 

 

 

 

 

E. Select A500GrB46 from the Material drop-down list – this is the ma-
terial property defined in the previous section. Clicking on the + but-
ton will display the Define Materials form where material properties 
may be altered or added.  

F. Scroll down the list of tubes in the Select Sections to Import area un-
til you find HSS8X8X3/8. Click once on that member to highlight it. 

G. Click the OK button, and then click the OK button in the Box/Tube 
Section form to add the tube selected to the list in the Properties area 
on the Frame Properties form.    

H. Do not close the Frame Properties form - it will be required in the 
next segment of the tutorial.    

 

2 - 10 Step 1    Begin a New Model 



Chapter 2 - An Introductory Tutorial 

Define an Auto Select Section List 
An auto select section list is simply a list of sections. Auto select section 
lists are assigned to frame objects in the same manner as an  individual 
section property. When an auto select section list is assigned to a frame 
object, the program can automatically select the most economical, ade-
quate section from the list when designing the member. When perform-
ing the initial analysis, the program will assign the median section from 
the list for the analysis properties. 

For this particular tutorial, the program will analyze and design the truss-
es from a set of W shapes (W8X10 thru W8X67), which will be chosen 
from an auto select sections list created now. 

A. With the Frame Properties form displayed, click the Import New 
Property button to display the Import Frame Section Property form.  

B. Verify that Steel is still showing in the Frame Section Property Type 
drop-down list, and then click the I/Wide Flange button, which will 
display the Sections8.pro sections list shown in Figure 12. 

 

 

 

 

 

 

Figure 12 
Sections8.pro 
sections  
list 
 

 

 

 Step 1    Begin a New Model 2 - 11 



SAP2000 

C. Select A992Fy50 from the Material drop-down list – this is the de-
fault steel material property.  

D. Scroll down the list of shapes in the Select Sections to Import area 
until you find W8X10. Click once on that member to highlight it. 

E. Scroll further down the list until you find W8X67. Hold down the 
Shift key on your keyboard and click once on W8X67; a collection of 
W8s should now be highlighted. 

F. Click the OK button, and then click the OK button in the I/Wide 
Flange Section form to add the shapes selected to the list in the Prop-
erties area on the Frame Properties form.    

G. Click the Add New Property button in the Click to area of the 
Frame Properties form and the Add Frame Section Property form 
will display. 

H. In the Frame Section Property Type drop-down list, select Steel.  

I. Click the Auto Select List button to display the Auto Selection Sec-
tions form shown in Figure 13. 

 

 

 

 

 

Figure 13 
Auto 
Selection 
Sections 
form 
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J. Type TRUSS in the Auto Section Name edit box. 

K. Locate the W8X10 shape under the List of Sections, and click once to 
highlight it. 

L. Continue down the list until you find the last W shape, W8X67, and 
while holding down the Shift key on the keyboard, click once on this 
section. All of the W shapes should now be highlighted. 

M. Click the Add button to move the selected list to the Auto Selections 
edit box on the right side of the form. 

N. Click the OK button and then click the OK button on the Frame 
Properties form to accept your changes and add the TRUSS auto se-
lect list to the Properties list. 

Step 2    Add Frame Objects 
In this step, frame objects with the associated sections previously defined 
are drawn using the grids and snap-to options, and generated using Edit 
menu commands. 

Draw Frame Objects 
Make sure that the X-Y Plane @ Z=40 view is active (see Step 1-D for 
directions on how to make a view active). This view should be in the left 
window. Also check that the Snap to Points and Grid Intersections 
command is active. This will assist in accurately positioning the frame 
objects. This command is active when its associated button    is de-
pressed. Alternatively, use the Draw menu > Snap to > Points and 
Grid Intersections command. By default, this command is active. 

A. Click the View menu > Set 2D View command. 

1. Click on the Y-Z plane option. 

2. Type 0 into the X = edit box to display an elevation view, and 
click OK. 
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B. Click the Draw Frame/Cable  button or use the Draw menu > 
Draw Frame/Cable/Tendon command. If you accessed the Draw 
Frame/Cable/Tendon command via the Draw menu, the Draw 
Frame/Cable button will depress verifying your command selection. 
The Properties of Object pop-up form for frames will appear as 
shown in Figure 14.  

 

 
Figure 14 
Properties of 
Object form 
 

 

If the Properties of Object form is covering any part of the model in 
either view, click on the blue title bar and drag it out of the way. 

C. Click in the Section drop-down list on the Properties of Object form 
and scroll down to HSS8X8X3/8. Single click on it to assign this sec-
tion to the members you will draw. 

D. To draw the first frame object, left click once in the Y-Z Plane view 
at the Y-Z origin (lower left corner of the grid), and then click again 
along the vertical grid at the Grid Point that gives L=24.00 (y=0, 
z=24). The cursor location is indicated in the lower right-hand corner 
of the interface. A frame line should appear in both views (elevation 
and 3D). After clicking to define the end point of the frame object, 
right click to “lift the pen” so you will no longer be actively drawing, 
but will leave the Draw Frame/Cable/Tendon command active so 
that you may add additional objects. 

If you have made a mistake while drawing this object, click the Set 
Select Mode  button, to leave the Draw mode and go to the Select 
mode. Then click the Edit menu > Undo Frame Add command, 
and repeat Items B-D. 
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E. Draw another column by clicking on the other side of the grid at Grid 
Point (y=36, z=0) to start, and then click again at Grid Point (y=36, 
z=24) to draw a vertical member with a L=24.00. 

F. Click the right mouse button to "lift" the pen. 

G. Return to the Properties of Object form and select TRUSS from the 
Section drop-down list. This will assign the auto select list TRUSS to 
the next members you will draw. 

H. In the Y-Z Plane @ X=0 view, a bottom chord will be drawn. Click 
at Grid Point (y=0, z=20) to start, and then click again at Grid Point 
(y=36, z=20) to draw a horizontal member with L=36.00. Click the 
right mouse button to lift the pen. 

Note that the bottom chord was drawn as a single "physical" object, 
similar to the way that it would typically be constructed. No regard 
was paid to where the other truss members frame into it. In order to 
maintain connectivity with the other truss members, i.e., diagonals 
and verticals, SAP2000 will automatically mesh this chord object in-
to multiple internal elements when performing the analysis. Howev-
er, when reporting results and doing design, SAP2000 will treat the 
chord as a single "physical" member. 

I. Next draw a top chord. Click at Grid Point (y=0, z=24) to start, and 
then click again at grid Point (y=36, z=24). 

J. With the draw mode still active, click on t he lower chord one grid 
line over at Grid Point (y=30, z=20) to draw the first diagonal mem-
ber. Draw additional verticals and diagonals by clicking at the fol-
lowing Grid Points; (y=30, z=24); (y=24, z=20); (y=24, z=24); 
(y=18, z=20); and (y=18, z=24). 

K. Click the right mouse button to lift the pen. 

L. Draw the next series of diagonals and verticals by clicking at Grid 
Point (y=18, z=20) to start, and then clicking at the following Grid 
Points: (y=12, z=24); (y=12, z=20); (y=6, z=24); (y=6, z=20); and 
(y=0, z=24). 
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M. Click the Set Select Mode  button, or press the Esc key on t he 
keyboard to exit the Draw Frame/Cable/Tendon command. 

Assign Member End Releases 
Make sure that the program is in the Select mode, and that the Y-Z view 
is active. 

A. Select the internal diagonal and vertical members spanning between 
the longitudinal chords by left clicking directly on the members, or 
left clicking to the right of the objects, holding the left mouse button 
down, and dragging the mouse across the members. See Figure 15 
for selection options.  

The status bar in the lower left of the program window should show 
11 Frames Selected. 

 

 

 

 

Figure 15 
Graphical 
Selection 
Options 
 

 

 

 

 

B. Click the Assign menu > Frame > Releases/Partial Fixity com-
mand to access the form shown in Figure 16. Check the Moment 33 
(Major) check boxes for both the Start and End Releases.  
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By releasing the moments in the major direction, the diagonals and 
verticals in the trusses will behave as pinned elements. 

C. Click the OK button to accept the changes and return to the Select 
mode. 

 

 

 

Figure 16  
Assign Frame  
Releases form 

 

 

 

 

 

 

D. Click the Assign menu > Clear Display of Assigns command to 
remove the Frame Releases identifiers. 

Divide Frame Objects 
SAP2000 allows members to be sub-divided into multiple objects after 
they are drawn to accommodate changes in geometry (this differs from  
the internal meshing done during analysis where the number of objects 
remains the same). In this tutorial, the top chord of the truss was drawn 
as a single object, but will be divided in two at midspan to allow for the 
sloped roof. 

Make sure that the program is in the Select mode, and that the Y-Z view 
is active. 
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A. Select the top chord of the truss (the horizontal member at elevation 
z=24) by left clicking directly on the member. 

B. Click the Edit menu > Edit Lines > Divide Frames command to 
access the form shown in Figure 17.  

 

 

 

Figure 17  
Divide  
Selected 
Frames 
form 

 

 

 

C. Select the Divide into Specified Number of Frames option in the Di-
vide Selected Straight Frame Objects area. 

D. Type 2 into the Number of Frames edit box. 

E. Type 1 into the Last/First Length Ratio edit box. 

F. Click the OK button to accept the changes and return to the Select 
mode. 

Save the Model 
During development, save the model often. Although typically you will 
save it with the same name, on occasion you may want to save it with a 
different name to record your work at various stages of development.   

A. Click the File menu > Save command, or the Save  button, to 
save your model. Specify the directory in which you want to save the 
model and, for this tutorial, specify the file name Tutorial Building. 
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Step 3    Add Restraints 
In this step, supports for the columns are defined. Make sure that the Y-Z 
Plane @ X=0 view is still active, and that the program is in the  
Select mode. 

A. Click on the two joints marking the bottom ends of the two columns 
(y=0, z=0 and y=36, z=0). The status bar in the lower left corner 
should show 2 Points Selected. 

B. Click on the Assign menu > Joint > Restraints command to access 
the Joint Restraints form shown in Figure 18.  

C. Click on the Pinned  button to assign restraints in the Translation 
1, 2, and 3 directions for these two joints. Click OK to accept the as-
signment. 

 

 

Figure 18 
Joint 
Restraints 
form 
 

 

 

 

 

D. Click the File menu > Save command, or the Save  button, to 
save your model. 
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Step 4    Replicate Frame Objects 
In this step, the planar frame just drawn will be replicated at three addi-
tional locations. 

Make sure that the program is in the Select mode.  

A. Click the Select > Select > All command, or the Select All  but-
ton, to select the entire model. The status bar should show 16 Points 
16 Frames Selected.  

B. Click the Edit menu > Replicate command to access the form 
shown in Figure 19.  

C. On the Linear tab, type 12 into the dx edit box. 

D. Type 3 into the Number edit box. 

E. Click the OK button. Note that three additional frames have been 
generated. 

 

 

 

 

 

Figure 19 
Replicate 
form 
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Draw Additional Frame Objects 
Make sure that the program is in the Select mode, and that the Y-Z view 
is active. 

A. Click the View menu > Set 2D View command. 

1. In the Set 2D View form click on the X-Z plane option. 

2. Type 0 into the Y= edit box to display an elevation view, and 
click OK. 

B. Click the Draw Frame/Cable  button or use the Draw menu > 
Draw Frame/Cable/Tendon command to display the Properties of 
Object form. 

C. Select W8X31 from the Section drop-down list. This will assign this 
section to the next members you will draw. 

D. In the X-Z Plane @ Y=0 view, click at Grid Point (x=0, z=24) to 
start, and then click again at Grid Point (x=36, z=24) to draw a hori-
zontal member with L=36.00. Click the right mouse button to lift the 
pen. 

E. Click at Grid Point (x=0, z=20) to start and then click at Grid Point 
(x=36, z=20) to draw another member parallel to the one just drawn. 

F. Click the Set Select Mode  button, or press the Esc key on t he 
keyboard to exit the Draw Frame/Cable/Tendon command. 

G. Select the two horizontal members just drawn by left clicking direct-
ly on the objects. 

H. Click on the Assign menu > Frame > Automatic Frame Mesh 
command to access the form in Figure 20. Select the Auto Mesh 
Frame option and check the at Intermediate Joints and at Intersec-
tion with Other Frames check boxes, and click OK. 

This meshing is done to ensure connectivity between the beams and 
the columns because the beams were drawn as single “physical” ob-
jects. In reality, it is unlikely that a single beam would be used, and 
therefore better practice would be to divide these beams into multiple 
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objects spanning between the columns. But since dividing a frame 
was illustrated earlier in the tutorial, it was decided that these mem-
bers would be meshed to demonstrate this feature. With that said, 
note that this meshing step was not absolutely necessary as the de-
fault was set to at Intermediate Joints.  

 

 

 

 

Figure 20 
Assign 
Automatic 
Frame Mesh 
form 
 

 

 

I. Click the Assign menu > Clear Display of Assigns command. 

J. Click the Get Previous Selection  button or use the Select menu 
> Get Previous Selection command to again select the two horizon-
tal beam objects. 

K. Click the Edit menu > Replicate command to access the Replicate 
form. 

1. Type 0 into the dx edit box, 36 into the dy box, and 0 into the dz 
box. 

2. Type 1 into the Number edit box. 

3. Click OK to accept the changes. 

The framing will be replicated at the other side of the building. 
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L. Click the File menu > Save command, or the Save  button, to 
save your model. 

Step 5    Add Area Objects 
In this step, a concrete roof is added to the model. 

Define the Area Sections 
Make sure that the X-Z view is active.  Now switch to a “plan” view, and 
define the properties for the concrete deck. 

A. Click the View menu > Set 2D View command. In the Set 2D View 
form, click the X-Y plane option, type 24 into the Z = edit box and 
click the OK button. 

B. Click the Define menu > Section Properties > Area Sections 
command.  The Area Sections form will display. 

C. Make sure that the Select Sec-
tion Type to Add item is set to 
Shell. Click the Add New 
Section button in the Click to 
area of the form. The Shell 
Section Data form shown in 
Figure 21 displays. 

 

 

 

Figure 21 
Shell Section Da-
ta 
form 
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1. Type ROOF into the Section Name edit box. 

2. Select the Shell-Thin option in the Type area. 

3. Verify that the Material Name is set to 4000Psi in the Material 
area. Clicking on the + button will display the Define Materials 
form where material properties may be altered or added. 

4. Set the Thickness (both Membrane and Bending) to 0.4167 (or 5 
in) to indicate that the concrete roof is 5 inches thick. By defini-
tion, a Shell object has both Membrane and Bending behavior. 

5. Click the OK button and then click the OK button in the Area 
Sections form to complete the roof definition.  

Draw the Area Object 
Make sure that the X-Y Plane @ Z=24 view is active.  Now draw an area 
object to represent a roof panel using the following Action Items. 

A. Click the Draw Poly Area button , or go to the Draw menu > 
Draw Poly Area command. The Properties of Object pop-up form 
for areas will display as shown in Figure 22. 

Make sure that the Section item in this box is set to ROOF. If it is  
not, click once in the drop-down list opposite the Section item to ac-
tivate the drop-down list and select ROOF from the list.  

 
Figure 22 
Properties of 
Object box 

 

B. Check that the Snap to Points and Grid Intersections command is 
active. This will assist in accurately drawing the area object. 

C. Click once at point (x=0,y=0). Then moving counter-clockwise 
around the model, click once at these object points in this order to 
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draw the outline of the roof: (x=12,y=0), (x=12,y=18) and 
(x=0,y=18).  

D. Press the Enter key on your keyboard to stop drawing. 

E. Click on the Set Select Mode  button, or Press the Esc key on the 
keyboard to exit the Draw Poly Area command. 

F. To better view the deck addition, click the Set Display Options  
button, or go to the View menu > Set Display Options command.  
When the form appears, check the Fill Objects check box a nd the 
Apply to All Window check box, as shown in Figure 23.  

 
Figure 23 
Display Options for Active Window form 

G. Click OK to accept the changes.  

H. Click anywhere in the 3-D View (right window) to make it active. 

I. In order to make it easier to differentiate between the frame members 
and the grid, click on t he View menu > Show Grid command to 
toggle off the grid in the 3-D View. The model should now appear as 
shown in Figure 24. 
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Figure 24 
Model after an area object has been drawn 

Mesh the Area Object 
The area object will now be meshed similar to the previous meshing of 
frame objects.  

A. Click anywhere in the X-Y Plane @ Z=24 view to make it active. 

B. Right click anywhere on the area object to display the Object Model 
– Area Information form shown in Figure 25. 

C. Click on the Assignments tab on the Object Model – Area Infor-
mation form. 

D. Double click in the edit box opposite the Automatic Area Mesh item 
to display the Assign Automatic Area Mesh form shown in Figure 
26. 

E. Select the Mesh Area Based On Points On Area Edges option. 
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F. Check the Intersections of Straight Line Objects In Meshing Group 
With Area Edges and the Point Objects In Meshing Group That Are 
on Area Edges check boxes. 

The area object representing the roof panel was drawn as a single ob-
ject, but needs to be meshed into multiple analysis elements so that 
there will be connectivity between the roof and the intermediate 
points along the chord elements. Meshing, unlike dividing, does not 
create new objects. If the Edit menu > Edit Areas > Divide Areas 
command were to be used, new objects would be created. 

 

 

 

 

 

Figure 25 
Object Model –  
Area Information form 

 

 

 

 

 

G. Click the OK button and then the OK button on the Object Model – Area Infor-
mation form to complete the area object meshing. 
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Figure 26 
Assign Automatic Area Mesh form 

 

Replicate Area Objects 
Make sure that the X-Y Plane @ Z=24 view is active.  

A. Click the Select > Select > Properties > Area Sections command to 
display the Select Sections form shown in Figure 27. 

 

 
Figure 27 
Select 
Sections 
form 
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B. Click ROOF in the Select area to highlight it. 

C. Click on the OK button to select the area object. 

D. Click the Edit menu > Replicate command to access the Replicate 
form.  

E. On the Linear tab, type 12 into the dx edit box, 0 into the dy edit box, 
and 0 into the dz edit box. 

F. Type 2 into the Number edit box. 

G. Click the OK button. Note that two additional roof panels have been 
drawn. 

H. Click the Select > Select > Properties > Area Sections command to 
display the Select Sections form.  

I. Select ROOF and click the OK button. The status bar should show 3 
Areas, 12 Edges Selected. 

J. Click the Edit menu > Replicate command to access the Replicate 
form. 

K. On the Linear tab, type 0 into the dx edit box, 18 into the dy edit box, 
and 0 into the dz edit box. 

L. Type 1 into the Number edit box. 

M. Click the OK button. Note that roof panels have been drawn on the 
other side of the building. 

Step 6    Move Objects 
In this step, objects are moved to create the roof slope. Make sure that 
the X-Y Plane @ Z=24 view is still active, and that the program is in the  
Select mode. 

A. Click on the Select > Select > Coordinate Specification > Speci-
fied Coordinate Range command to display the Select By Specified 
Coordinate Range form shown in Figure 28. 
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B. Select the Not Limited option in the X Coordinate Limits area. 

C. Select the At A Single Value option in the Y Coordinate Limits area 
and select = from the Operator drop-down list, and type 18 into the 
Value edit box, and 1 into the Tolerance edit box. 

D. Select the At A Single Value option in the Z Coordinate Limits area 
and select = from the Operator drop-down list, and type 24 into the 
Value edit box, and 1 into the Tolerance edit box. 

 

 

Figure 28 
Select By 
Specified 
Coordinate 
Range form 
 

 

 

 

 

 

 

 

E. Click on the OK button to accept the changes. The status bar should 
show 4 Points Selected. 

F. Click the Edit menu > Move command to display the Move form 
shown in Figure 29. 
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Figure 29 
Move 
form 

 

 

 

G. Type 3 into the Delta Z edit box in the Change Coordinates by: area. 

H. Click the OK button. Note that the ridge line of the roof has moved 
up. 

I. Click on the Select menu > Select > Coordinate Specification > 
Specified Coordinate Range command to display the Select By 
Specified Coordinate Range form. 

J. Select the Not Limited option in the X Coordinate Limits area. 

K. Select the Between Two Values option in the Y Coordinate Limits ar-
ea and select >= from the first Operator drop-down list, and type 12 
into the first Value edit box. Select <= from the second Operator 
drop-down list, and type 24 into the second Value edit box. 

L. Select the At A Single Value option in the Z Coordinate Limits area 
and select = from the Operator drop-down list, and type 24 into the 
Value edit box, and 1 into the Tolerance edit box. 

M. Click on the OK button to accept the changes. The status bar should 
show 8 Points Selected. 

N. Click the Edit menu > Move command to display the Move form. 

O. Type 2 into the Delta Z edit box in the Change Coordinates by: ar-
ea. 
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P. Click the OK button. Note that additional truss members have 
aligned with the roof. 

Q. Click on the Select menu > Select > Coordinate Specification > 
Specified Coordinate Range command to display the Select By 
Specified Coordinate Range form. 

R. Select the Not Limited option in the X Coordinate Limits area. 

S. Select the Between Two Values option in the Y Coordinate Limits 
area and select >= from the first Operator drop-down list, and type 
6 into the first Value edit box. Select <= from the second Operator 
drop-down list, and type 30 into the second Value edit box. 

T. Select the At A Single Value option in the Z Coordinate Limits area 
and select = from the Operator drop-down list, and type 24 into the 
Value edit box, and 1 into the Tolerance edit box 

U. Click on the OK button to accept the changes. The status bar 
should show 8 Points Selected. 

V. Click the Edit menu > Move command to display the Move form. 

W. Type 1 into the Delta Z edit box in the Change Coordinates by: ar-
ea. 

X. Click the OK button. Note that additional truss members have 
aligned with the roof. 

Y. Click the View menu > Set 2D View command. In the Set 2D 
View form, click the Y-Z plane option, type 0 into the X = edit box 
and click the OK button. The model should now appear as shown 
in Figure 30. 
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Figure 30 
Model after object move 

Step 7    Assign Area Stiffness Modifiers 
In this step, the membrane properties of the area objects are modified to 
prohibit the roof panels from acting as flanges for the top chords of the 
trusses. 

A. Click anywhere in the 3-D View to make it active 

B. Click Select menu > Select > Properties > Material Properties to 
display the Select Properties form shown in Figure 31.  

C. Click 4000Psi in the Select area to highlight it. 

D. Click on the OK button to select all of the concrete area objects. 
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Figure 31 
Select 
Sections 
form 

 

 

E. Click the Assign menu > Area > Area Stiffness Modifiers com-
mand to access the Property/Stiffness Modification Factors form 
shown in Figure 32.  

1. Type 0 in the Membrane f22 Modifier edit box. 

This action will prohibit the roof area objects from carrying in-
plane axial loads. 

2. Click OK to accept the assignment.   

 

 

 

 

Figure 32 
Property/Stiffness 
Modification 
Factors form 
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F. Click the Assign menu > Clear Display of Assigns command to 
clear the display of the stiffness modifiers. 

G. Click the File menu > Save command, or the Save  button, to 
save your model. 

Step 8    Define Load Patterns 
The loads used in this tutorial consist of dead, live and wind static load 
patterns. The dead and live loads act in the gravity direction, while the 
wind load will be applied as a surface pressure to the roof objects. 

For this example, assume that the dead load pattern consists of the self-
weight of the building plus an additional 20 kips at each lower chord 
panel point of each truss. The live load pattern is taken to be 30 pounds 
per square foot (psf) applied to the projected area of the concrete roof. 
The wind load pattern is taken to be 15 psf applied to the windward roof, 
and 6 psf applied to the leeward side of the roof. 

A. Click the Define menu > Load Patterns command to access the  
Define Load Patterns form shown in Figure 33. Note there is only a 
single default load pattern defined, which is a dead load pattern with 
self-weight (DEAD). 

 
Figure 33 
Define Load Patterns form 
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Note that the self-weight multiplier is set to 1 for the default pattern. 
This indicates that this load pattern will automatically include 1.0 
times the self-weight of all members.  

In SAP2000, both Load Patterns and Load Cases exist, and they may 
be different. However, the program automatically creates a co rre-
sponding load case when a load pattern is defined, and the load cases 
are available for review at the time the analysis is run. 

B. Click in the edit box for the Load Pattern Name column. Type the 
name of the new pattern, LIVE. Select a Type of load pattern from 
the drop-down list; in this case, select LIVE. Make sure that the Self 
Weight Multiplier is set to zero. Click the Add New Load Pattern 
button to add the LIVE load pattern to the load list. 

C. Click in the edit box for the Load Pattern Name column once again. 
Type the name of the last new pattern, WIND. Select WIND from 
the Type drop-down list. Make sure that the Self Weight Multiplier 
is set to zero, and that None is showing in the Auto Lateral Load Pat-
tern drop-down list. Click the Add New Load Pattern button to add 
the WIND load pattern to the load list. 

The Define Load Patterns form should now appear as shown in Fig-
ure 34. Click the OK button in that form to accept the newly defined 
load patterns.  

 
Figure 34 
The Define Load Patterns form after all of the load patterns have been defined 
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Step 9    Assign Loads 
In this step, the dead, live and wind loads will be applied to the model. 
Make the Y-Z Plane @  X=0 view active, and check to make sure that 
the program is in the Select mode. 

A. Click on each of the panel points on the bottom chord of the truss. 
The status bar should show 5 Points Selected. If you make a mistake 
in selecting, click the Clear Selection  button, and try again. 

B. Select the Assign menu > Joint Loads > Forces command to access 
the Joint Forces form. Select DEAD from the Load Pattern Name 
drop-down list as shown in Figure 35. Clicking on the + button will 
display the Define Load Patterns form where load patterns may be 
altered or added. 

1. Type -20000 in the Force Global Z edit box in the Loads area. 
The minus sign indicates that the load is applied in the negative 
Global Z direction. 

  

 

Figure 35 
Joint Forces 
form 

 

 

 

 

2. Click the OK button to accept the dead load. 

C. Click the Get Previous Selection  button or use the Select menu 
> Get Previous Selection command to again select the bottom chord 
panel points. 
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D. Click the Edit menu > Replicate command to display the Replicate 
form. 

1. On the Linear tab, type 12 into the dx edit box, 0 into the dy edit 
box, and 0 into the dz edit box. 

2. Type 3 into the Number edit box. 

3. Click the OK button to accept the changes 

E. Click the Select menu > Select > Properties > Area Sections com-
mand to display the Select Sections form. 

1. Click on ROOF in the Select area to highlight it. 

2. Click the OK button to select all of the roof area objects. 

F. Select the Assign menu > Area Loads > Uniform (Shell) command 
to access the Area Uniform Loads form. Select LIVE from the Load 
Pattern Name drop-down list as shown in Figure 36. 

  

 

Figure 36 
Area Uniform 
Loads form 

 

 

 

 

1. Type 30 in the Load edit box in the Uniform Load area. 

2. Select Gravity Projected from the Direction drop-down list.  
Remember that the Gravity direction is in the negative Global Z 
direction. 

3. Click the OK button to accept the live load. 
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G. Click on the Select menu > Select > Coordinate Specification > 
Specified Coordinate Range command to display the Select By 
Specified Coordinate Range form. 

1. Verify that the Entirely Inside The Specified Selection Volume 
option is selected in the Select All Objects That Are: area. 

2. Uncheck all of the check boxes except for Area in the Select 
These Object Types area. 

3. Select the Not Limited option in the X Coordinate Limits area. 

4. Select the Between Two Values option in the Y Coordinate Lim-
its area and select >= from the first Operator drop-down list, and 
type 0 into the first Value edit box. Select <= from the second 
Operator drop-down list, and type 18 into the second Value edit 
box. 

5.  Select the Not Limited option in the Z Coordinate Limits area. 

6. Click the OK button to select the roof area objects on the wind-
ward side. The status bar should show 3 Areas, 12 Edges Select-
ed. 

H. Click the Assign menu >  Area Loads > Surface Pressure (All) 
command to display the Area Surface Pressure Load form shown in 
Figure 37. 

  

 

Figure 37 
Area Surface 
Pressure Load 
form 
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1. Select WIND from the Load Pattern Name drop-down list. 

2. Select the By Element option in the Pressure area. 

3. Type 15 in the Pressure edit box. 

4. Select Top from the Face drop-down list. 

5. Click the OK button to apply a wind pressure load inward to the 
top face of the windward roof area objects. 

I. Click on the Select menu > Select > Coordinate Specification > 
Specified Coordinate Range command to display the Select By 
Specified Coordinate Range form. 

1. Verify that the Entirely Inside The Specified Selection Volume 
option is selected in the Select All Objects That Are: area. 

2. Verify that only the check box for Area in the Select These Ob-
ject Types area is checked. 

3. Select the Not Limited option in the X Coordinate Limits area. 

4. Select the Between Two Values option in the Y Coordinate Lim-
its area and select >= from the first Operator drop-down list, and 
type 18 into the first Value edit box. Select <= from the second 
Operator drop-down list, and type 36 into the second Value edit 
box. 

5.  Select the Not Limited option in the Z Coordinate Limits area. 

6. Click the OK button to select the roof area objects on the lee-
ward side. The status bar should show 3 Areas, 12 Edges Select-
ed. 

J. Click the Assign menu > Area Loads > Surface Pressure (All) 
command to display the Area Surface Pressure Load form. 

1. Select WIND from the Load Pattern Name drop-down list. 

2. Select the By Element option in the Pressure area. 
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3. Type -6 in the Pressure edit box. 

4. Select Top from the Face drop-down list. 

5. Click the OK button to apply a wind pressure load outward to 
the top face of the leeward roof area objects. 

K. Click the Assign menu > Clear Display of Assigns command to 
clear the display of the assigned loads. 

L. Click the File menu > Save command, or the Save  button, to 
save your model. 

Step 10   Define Load Combinations 
In this step, the steel design code will be selected and the load combina-
tions required for design will be automatically generated. 

A. Click the Design menu >  Steel Frame Design > View/Revise 
Preferences command to display the Steel Frame Design Prefer-
ences form shown in Figure 38.  

  

 

Figure 38 
Steel Frame 
Design Preferences 
 form 
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B. Select AISC360-05/IBC2006 from the Design Code drop-down list. 

C. Click the OK button to accept the design code changes. 

D. Select the Define menu > Load Combinations command to display 
the Define Load Combinations form. 

E. Click the Add Default Design Combos... button to display the Add 
Code-Generated User Load Combinations form shown in Figure 39.  

  

 

Figure 39 
Add Code-Generated 
User Load  
Combinations form 

 

 

 

 

F. Select the Steel Frame Design option under the Select Design Type 
for Load Combinations area. 

G. Click the Set Load Combination Data button to display the Code-
Generated User Load Combinations for Steel Frame Design form 
shown in Figure 40.  

H. Uncheck the Deflection checkbox in the Limit States for which User 
Defined Load Combinations are to be Generated area - this tutorial is 
concerned only with strength limit states. 

I. Click the OK button twice to return to the Define Load Combina-
tions form. Note that a total of eight load combinations have been 
generated.  

1. Click on UDSTL3 in the Load Combinations area to highlight it. 
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2. Click the Modify/Show Combo button to display the Load 
Combination Data form. Note that this particular combination 
consists of 1.2 DEAD + 1.0 LIVE + 1.6 WIND. 

3. Click the OK button to return to the Define Load Combinations 
form. 

J. Repeat Step I for other load combinations if so desired, or click the 
OK button to leave the Define Load Combinations form. 

 

Figure 40 
Code-Generated 
User Load  
Combinations 
for Steel Frame 
Design form 

 

 

 

 

Step 11   Run the Analysis 
In this step, the analysis model will be viewed and the analysis will be 
run. 

A. Click anywhere in the 3-D View to make it active. 

B. Click the Set Display Options    button. When the form appears, 
check the Show Analysis Model check box as shown in Figure 41. 
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Figure 41 
Display Options for Active Window form 

C. Click the OK button to accept the display setting. 

D. If the model has not previously been analyzed, a message similar to 
the one in Figure 42 displays. 

 
 
 

 
Figure 42 
Analysis Model message 

 

E. Click the Yes button to display the analysis model. Take a moment 
to verify that the element formation is as expected. 

F. Click the Analyze menu > Run Analysis command or the Run 
Analysis  button, to access the Set Load Cases to Run form as 
shown in Figure 43.  
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Figure 43 
Set Load 
Cases to Run  
form 

 

 

 

Note that the program has automatically defined four different load 
cases: DEAD, MODAL, LIVE and WIND based on the load patterns 
defined previously, as well as the assumption that the program may 
need modal properties for some analysis options, even though no dy-
namic functions have been defined. 

1. Select MODAL from the Case Name list. 

2. Click the Run/Do Not Run Case button to set the action for 
MODAL to Do Not Run, as we intend to run only a static analy-
sis. 

3. Click the Run Now button.  

The program will create the analysis model from your object-based 
SAP2000 model and an analysis monitor window may display, de-
pending on the duration of analysis. Analysis information may be ac-
cessed at a later time by going to the File menu > Show Input/Log 
Files command and selecting the file with the .LOG extension. 

G. When the analysis is finished, the program automatically displays a 
deformed shape view of the model, and the model is locked. The 
model is locked when the Lock/Unlock Model      button appears 
depressed. Locking the model prevents any changes to the model that 
would invalidate the analysis results. 
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Step 12  Graphically Review the Analysis Results 
In this step, the analysis results will be reviewed using graphical repre-
sentation of the results. 

A. With the left view active, click the Set YZ View button,       , in or-
der to set the left window to a Y-Z Plane @ X=0 view. 

B. Click the Show Forces/Stresses > Frames/Cables/Tendons button,      
, or the Display menu > Show Forces/Stresses > 

Frames/Cables/Tendons command to bring up the Member 
Force/Stress Diagram for Frames form shown in Figure 44.  

1. Select DEAD from the Case/Combo Name drop-down list. 

2. Select the Force and Axial Force options. 

3. Select the Auto option under the Scaling area.  

 
 

 

 

 

Figure 44 
Member Force/Stress  
Diagram for 
Frames form 

 

 

 

 

 

4. Select the Fill Diagram option. 
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5.  Click the OK button to generate the axial force diagram shown 
in Figure 45.  

 
 
 
 
 
 

Figure 45 
Axial force diagram in 
an elevation view 

 
 
 
 
C. Right click on the bottom chord member in the Y-Z view to access 

the Diagram for Frame Object form shown in Figure 46. 

 

 

 

Figure 46 
Force details  
obtained by  
right-clicking 
bottom chord of 
truss in the  
elevation view in  
Figure 45 
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Note that the program displays the force diagrams for the entire bot-
tom chord object just as it was drawn, even though the program has 
automatically meshed the frame object into smaller elements for 
analysis. 

1. Click the Scroll for Values option in the Display Options area, 
and move the mouse over the diagrams with the left button held 
down to obtain values at any location. 

2. Click the Done button to close the form.  

D. Make sure that the Y-Z View is active, and then click the Display 
menu > Show Deformed Shape command or the Show Deformed 
Shape  button to access the Deformed Shape form shown in Fig-
ure 47.  

1. Select LIVE from the 
Case/Combo Name 
drop-down list. 

2. Check the Cubic 
Curve check box. 

3. Click the OK button 
to generate the de-
formed shape shown 
in Figure 48.  

 

Figure 47 
Deformed Shape form 
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Figure 48 
Deformed Shape in an elevation view 
 
 

E. Right click on the middle joint on the top chord object in Figure 48 
to display the Joint Displacements results form shown in Figure 49.  

 

Figure 49 
Joint Displacements  
obtained by right-clicking  
a joint shown in the  
elevation view in  
Figure 48 
 

Note that local object axis 3 is in the positive global Z direction. 

F. Close the Joint Displacements form by clicking the X in the upper 
right-hand corner of the form, or by clicking anywhere other than on 
the form. 
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Step 13   Design the Steel Frame Objects 
In this step, the steel frame members of the trusses will be designed. 
Note that the analysis should be run before completing the following  
Action Items. 

A. Click the Design menu > Steel Frame Design >View/Revise Pref-
erences command. The Steel Frame Design Preferences form shown 
in Figure 50 displays.  

 
Figure 50 
Steel Frame Design Preferences form 

1. Remember that back in Step 10 the Design Code was set to 
AISC360-05/IBC2006. Click in the Design Code drop-down list 
to see the many other available design codes. Return to the 
AISC360-05/IBC2006 code. The user is encouraged to examine 
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the design code options available using the Design menu > Steel 
Frame Design > View/Revise Preferences command. 

2. Review the information contained in the other items and then 
click OK to accept the selections. 

B. Click the Design menu > Steel Frame Design > Start Design/ 
Check of Structure command or the Start Steel Design/Check of 
Structure  button, to start the steel frame design process. The 
program designs the steel members, selecting the optimum member 
size from the TRUSS auto select section list for the truss members, 
and checking the columns and other framing members that are not 
part of the truss. 

When the design is complete, the selected sizes and stress ratios are 
displayed on the model. The model appears as shown in Figure 51. 

 
Figure 51 
Model after the steel frame design 
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C. Click the Design menu > Steel Frame Design > Verify Analysis vs 
Design Section command. A message similar to the one in Figure 52 
appears. Click the No button to close the form.  

 

Figure 52 
Analysis vs  
Design Section  

 

 

In the initial analysis (Step 11), the program used the median section 
by weight from the TRUSS auto select section list for the truss 
members. During design (this step), the program selected different 
sections by optimizing from the auto select list of members con-
tained in TRUSS. The number of iteration cycles is only one. Be-
cause new member sizes are now present in the model, the original 
analysis results are no longer valid and the analysis should be rerun. 

The goal is to repeat the analysis and design process until the analy-
sis and design sections for the truss are all the same. Note that when 
the building is reanalyzed, SAP2000 will use the current design sec-
tions (i.e., those selected in Step 13) as new analysis sections for the 
next analysis run. 

D. Right click on one  of the truss bottom chord members in the Y-Z 
view (shown in Figure 51). The Steel Stress Check Information form 
shown in Figure 53 displays. Note that the reported analysis and de-
sign sections are different.  

The main body of the form lists the design stress ratios obtained at 
various stations along the frame object for each design load combi-
nation. Note that the program has automatically created code-specific 
design load combinations in addition to the user specified combina-
tions previously defined in Step 10. In this instance, the two sets of 
combinations are identical as t hey were both generated from the 
same code specification.  
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Figure 53 
Steel Stress Check Information form 

Also note that the program designed the chord as a single physical 
member, just as it was drawn as a single object, even though the pro-
gram has automatically subdivided the frame object into smaller el-
ements for analysis.  

Click the Details button on the Steel Stress Check Information form. 
The Steel Stress Check Data AISC360-05/IBC2006 form shown in 
Figure 54 displays. Use the File menu on the form to print the data.   

Click the X in the upper right-hand corner of the Steel Stress Check 
Data AISC360-05/IBC2006 form to close it. Click the Cancel button 
to close the Steel Stress Check Information form. 

E. To rerun the analysis with the new analysis sections, click the Ana-
lyze menu > Run Analysis command or the Run Analysis  but-
ton, and then click the Run Now button on t he Set Load Cases to 
Run form. 
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Figure 54 
Steel Stress Check 
Dataform 

 

 

 

 

 

 

F. When the analysis is complete, click the Design menu > Steel 
Frame Design > Start Design/Check of Structure command or the 
Start Steel Design/Check of Structure  button, to start the steel 
frame design process. 

G. When the design is complete, click the Design menu > Steel Frame 
Design > Verify Analysis vs Design Section command. A message 
similar to the one in Figure 55 displays.  

 
 
Figure 55 
Analysis vs Design  
Section message 

 

 

The message in Figure 55 indicates the number of analysis sections 
that differ from the design sections. Click the No button if sections 
do not match, or the OK button if they do match, to close the form. 
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Repeat Action Items E through G until the message received indi-
cates that all analysis and design sections match. This may take nu-
merous iterations depending on the complexity of the model. 

H. When the analysis and design sections are the same, click the Design 
menu > Steel Frame Design > Verify All Members Passed com-
mand. A form similar to that shown in Figure 56 should appear indi-
cating that all members passed. 

 

Figure 56 
Stress/capacity  
check message 

 

Note that members not passing at this stage is an indication of inade-
quate sections, either in the auto select section list or in the other sec-
tion assignments. With the auto select section list, the program 
would have used the largest section in the list for both the analysis 
and design, so a message stating that members do not pass indicates 
that the auto select section list needs modification. In that case, add 
larger sections to the auto select sections list. For other members that 
do not pass, re-assign larger sections and continue the analysis and 
design iteration. 

I. Click the OK button to close the form. 

J. Click the File menu > Save command, or the Save  button, to 
save your model. 

This introductory tutorial is now complete. 
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