
 

©COMPUTERS AND STRUCTURES, INC., AUGUST 2010 

PRACTICAL HOW-TO GUIDE  
TECHNICAL NOTE 

2005 AISC DIRECT ANALYSIS METHOD 

This is a practical how-to guide for using the 2005 AISC Direct Analysis Method (DAM) 
in SAP2000, ETABS, and CSiBridge design. As an alternative to conventional  
design methods using equivalent length K factors, the DAM is a design procedure for 
stability analysis that uses K = 1. The DAM eliminates confusion and inconsistency in the 
application of K factors in conventional design, and may result in a more economical  
design. Equivalent length alignment charts are based on the often overly conservative  
assumption of sidesway buckling in a simplified elastic structure, commonly resulting in 
K factors of 2 to 3 or greater.  

First, let us review the DAM criteria in Appendix 7 Chapter C. The criteria are provided 
in boldfaced type. 

1.  Consider flexural, shear, and axial deformations of members. Those require-
ments are automatically accounted for in all ETABS, SAP2000, and CSiBridge anal-
yses.  

2.  Reduce member stiffness due to inelasticity, including residual stress, and in-
clude the effect of this stiffness reduction in the analysis of the structure. This is 
completed automatically within SAP2000, ETABS, and CSiBridge, except for 
SAP2000 versions prior to V11.0.7 for which users are required to assign reduction 
factors using frame property modifier forms. 

3.  Account for geometric imperfections, such as out-of-plumbness, which SAP2000, 
ETABS, and CSiBridge have automated through their "notional" lateral load 
case/load pattern definition. 

4.  Perform a rigorous nonlinear p-delta analysis that considers the effects of sway 
(load effects on a structure that has already laterally displaced) and local  
p-delta effects of loads on the deformed shape of individual members. Both of 
these requirements are automatically considered in SAP2000, ETABS, and 
CSiBridge p-delta analysis.  

Introduction 
SAP2000 has offered the Direct Analysis Method since V11.0, released in December 
2006. ETABS started offering DAM with Version 9.1.6. CSI continually strives to auto-
mate the design process for the engineer, and as a result of these efforts, there are some 
differences in how users approach DAM using our software, depending on the version, 
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and depending on if SAP2000, ETABS, or CSiBridge is being used. This guide attempts 
to point out these differences wherever applicable.  

Direct Analysis Method using SAP2000 Version 11.0.7 
 Specify design code and related design parameters using the Options menu > Preferences > 

Steel Frame Design command. At a minimum, specify the AISC360-05/IBC2006 code and 
stiffness reduction method in order to ensure that automatic load combinations are properly 
generated. 

 

 Reduction factors to section EI and EA are automatically applied by the program if the DAM 
Tau-b variable or Tau-b fixed option is selected. For the initial analysis, no reduction factors 
are used. However, as soon as a design is run the reduction factors are used and remain in the 
model. This means that the first time the model is analyzed and designed, users must iterate 
between design and analysis at least one additional time. Thereafter, both analysis and design 
will have reduction factors applied automatically. 

 Define notional loads for member geometric imperfections. Use the Define menu > Load 
Cases command to define gravity load cases (Dead and Live type), then click More under 
load "Type" to access the Notional load option. It does not matter if lateral loads are defined 
before or after Notional loads. Give the Notional load a descriptive name and click the Add 
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Load button with default Auto in the Auto Lateral Load column.  Then click the Modify Lat-
eral Load button to complete the definition. 

Users should define a Notional load for each grav-
ity load in both X and Y lateral directions, and 
SAP2000 will then automatically generate notion-
al lateral loads based on the specified proportion 
of the gravity load definitions. The default is to 
generate 0.002 of the specified gravity load as a 
notional lateral load (0.003 is required if the user 
designs using Tau-b fixed). Within the Analysis 
case definition, a negative multiplier can be sub-
sequently assigned to account for plus and minus 
directions of the lateral loads. 

 Define nonlinear load 
combinations. Users can 
define load combinations 
using the Define menu > 
Combinations command. 
Then select a combo(s) 
to be converted to non-
linear p-delta and click 
the Convert Combos to 
Nonlinear Cases button 
to automatically convert 
selected combos into 
nonlinear p-delta com-
bos.  

As an alternative to defining load cases 
manually, SAP2000 will automatically 
generate Default linear factored load 
combos when the Add Default Design 
Combos button is clicked and the Steel 
Frame design option shown in this 
screen capture is selected. After review-
ing the automatic design combos created 
by the program, users can then select / 
highlight combos and convert selected 
combos to Nonlinear cases as described 
previously.  

Make sure the design code is specified as AISC360-05/IBC2006 before using these steps to 
automatically create design combos. Otherwise, SAP2000 will not create the correct factored 
load combos because load combos vary among the design codes.  
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When using ASD the AISC360-05/IBC2006 code requires that, for design, the nonlinear  
p-delta analysis be carried out under 1.6 times the ASD load combinations and the results are 
to be divided by 1.6 to obtain the required strengths. The user will need to apply these ampli-
fications and reductions manually by creating separate analysis and design load combinations. 

 Auto-mesh (optional) for crea-
tion of additional joints. Alt-
hough SAP2000 and ETABS au-
tomatically consider small p-delta 
effects, in some cases users may 
need to add an additional joint be-
tween the I and J joints of their 
frames in a model to match better 
with some AISC benchmark prob-
lems. This is accomplished using 
the Assign menu > Frame > Au-
tomatic Frame mesh command. 
Use the Minimum Number of 
Segments option. Specifying two 
(2) segments is usually adequate.  
Unless the model is very large,  
the Automatic frame mesh option 
should not significantly affect 
analysis runtime.  

Note:  When importing older SAP2000 models designed with DAM in earlier versions V11.0 
through V11.0.6, SAP2000 will automatically reset the reduction factors unless the Options 
menu > Preferences > Steel Frame Design command is used to select the “No modification” 
option for the stiffness reduction method. 

Direct Analysis Method using SAP2000 Version 12 and later or CSiBridge 

The application of the Direct Analysis Method using SAP2000 Version 12 and later or 
CSiBridge is similar to SAP2000 Version 11.  The differences are described as follows.    

 Reduction factors to section EI and EA are automatically applied by the program if the DAM 
Tau-b variable or Tau-b fixed option is selected. For the initial analysis, no reduction fac-
tors are used. However, as soon as a design is run the reduction factors are used and remain in 
the model. This means that the first time the model is analyzed and designed, users must iter-
ate between design and analysis at least one additional time. Thereafter, both analysis and de-
sign will have reduction factors automatically applied.  

 Define notional loads for member geometric imperfections.  A significant difference in the 
terminology regarding load patterns, load cases and analysis cases appears in SAP2000 Ver-
sion 12 and CSiBridge.  In SAP2000 Version 12 or later and CSiBridge, Load Patterns are 
used in lieu of Load Cases and Load Cases are used in lieu of Analysis Cases.  Use the De-
fine menu > Load Patterns command in SAP2000 and the Loads > Load Patterns 
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> Load Patterns command in CSiBridge to 
define gravity load cases (Dead and Live 
type), then click More under load "Type" to 
access the Notional load pattern option. It 
does not matter if lateral load patterns are de-
fined before or after Notional load patterns. 
Give the Notional load pattern a descriptive 
name and click the Add New Load Pattern 
button with default Auto in the Auto Lat-
eral Load Pattern column. Then click the 
Modify Lateral Load Pattern button, which 
generates this form that can be used to com-
plete the definition.  

 Define nonlinear load combinations.  Users can define load combinations using the De-
fine menu > Load Combinations command in SAP2000 and the Design/Rating > 
Load Combinations > Expand arrow command. This form displays: 

 

 

 

Then, select a combo and then the Modi-
fy/Show button to get this form: 

 

 

 

 

To convert the load combination to a 
nonlinear p-delta load case, click the 
Create Nonlinear Load Cases from 
Combo button.  The load combination 
will be converted into a nonlinear load 
case as shown in the following figure: 
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As an alternative to defining load combinations manually, SAP2000 and CSiBridge will 
automatically generate linear Default Design Load Combinations when the Add Default De-
sign Combos button is clicked (on the Define Load Combinations form) and the Steel Frame 
design option (shown in the form below) is selected. After reviewing the automatic default 
design combos created by the program, the users can then select the desired combos and con-
vert them to Nonlinear load cases as described previously. 

Make sure the desired design code is speci-
fied, such as AISC360-05/IBC2006, before  
using these steps to automatically create  
design combos. Otherwise, the software will 
not create the correct factored load combos  
because load combos vary among the design 
codes. 

When using ASD the AISC360-05/IBC2006 
code requires that, for design, the nonlinear p-
delta analysis is carried out under 1.6 times 
the ASD load combinations and the results are 
to be divided by 1.6 to obtain the required 
strengths.   The user will need to apply these 
amplifications and reductions manually by 
creating separate analysis and design load 
combinations.  
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Direct Analysis Method using ETABS Version 9.1.6  
 Select design code and related design parameters using the Options menu > Preferences > 

Steel Frame Design command. At a minimum, select the AISC360-05 design code and the 
stiffness reduction method before defining load cases, because this will affect program gener-
ated default load combinations. 

 Reduction factors to section EI and EA are automatically assigned by the program for Tau-b 
variable and fixed options. For the initial analysis, no reduction factors are used. However, as 
soon as design has been run, the reduction factors are used and remain in the model. This 
means that the first time the model is analyzed and designed, users will have to iterate be-
tween design and analysis at least one additional time. Thereafter, both analysis and design 
will have reduction factors automatically applied and no further iteration will be necessary. 

 Definition of notional loads for member geometric imperfections. Use the Define menu > 
Load Cases command to define gravity load cases (Dead and Live type), then select the No-
tional load type. Give the notional load a descriptive name, click the Add Load button with 
the default Auto in the Auto Lateral Load column, and then click the Modify Lateral Load 
button.  

Users should define a notional load for each 
gravity load case in both X and Y lateral di-
rections and ETABS will then automatically 
generate Notional lateral loads based on that 
specified proportion of the gravity load def-
initions. The default is to generate 0.002 of 
the specified gravity load case as a notional 
lateral load case (0.003 is required if design-
ing Tau-b fixed, 0.002 for Tau-b variable). 
It does not matter if lateral load cases are 
defined before or after Notional loads, just 
as long as all gravity loads are defined first. 
Within the definition process initiated using 
the Define menu > Load Combinations 
command, a negative multiplier can be as-
signed to account for plus and minus direc-
tions of the lateral loads in a given combo. 
If  ETABS is allowed to automatically gen-
erate load combos, plus and minus lateral 
load cases will be generated in the load combinations. 

 Nonlinear load combinations are based on a user-specified p-delta case. Go to the Analyze 
menu > Set Analysis Options command and select the “Include P-Delta” option shown in the 
following screen capture to specify p-delta cases.  
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Click the Set P-Delta Parameters button to 
access the following form and define the 
nonlinear p-delta combo that will be the ba-
sis for all other loads and combos. DEAD 
case 1.2 scale factor and LIVE 1.0 factor 
would be a good basis for many designs, but 
you may want to scale them differently, de-
pending on your controlling load combos. If 
you have more than one DEAD case type, 
you would probably want to include them in 
this p-delta combo, with factors of 1.2 each.  

 

ETABS will automatically create factored load 
combinations based on load types that are ap-
plied after that p-delta combo. Alternatively, the 
Define menu > Load Combinations command 
can be used to define user custom load combina-
tions. If you defined your own load combos, use 
the Design menu > Steel Frame Design > Select 
Design Combo command to access the following 
form and remove any unwanted default load 
combinations for design, and replace them with 
user combinations. If automatic program gener-
ated load combinations are used, it is a good idea 
to review them before design.  
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Direct Analysis Method using SAP2000 Versions 11.0 through 11.0.6 
Between SAP2000 V11.0 and V11.0.6, the Variable Tau-b option was not automated, even 
though it appears in the design preferences drop-down options. Users of these versions must 
use Tau-b fixed. These versions do not automatically reduce section EI or EA. Those values 
have to be reduced by assigning section property modifiers. Beginning with SAP2000 V11.07 
and ETABS V9.1.6, reduction factors are automatically applied to EI and EA in accordance 
with code for both Tau-b Variable and Tau-b fixed. This means that in Versions 11.0 through 
V11.0.6 of SAP2000, users must select and assign modifiers to EI and EA to comply with the 
DAM, whereas starting in V11.0.7 this procedure is automated within the program. This is 
important to note because starting in SAP2000 V11.0.7/ETABS V9.1.6, any assignment of 
section property modifiers will be in addition to what the program automatically applies for 
DAM design. Use the Options menu > Preferences > Steel Frame Design command to speci-
fy the design code and related design parameters. 
 

 
 
 
 
 

Direct Analysis Method using SAP2000 Versions 11.0 through 11.0.6 Page 9 of 12 



Practical How-To Guide   2005 AISC Direct Analysis Method 

 Assignment of reduction factors to section 
EI and EA using V11.0 to V11.06.  Users 
must select frames and assign frame property 
modifiers to moments of inertia and cross-
sectional areas of frame members in their mod-
els before running the analysis and design.  
After frames have been selected, use the Assign 
menu > Frame > Property Modifiers command 
to assign reduction multipliers to EA and EI in 
accordance with the code.  

 

 

 Definition of notional loads to account for 
member geometric imperfections. Use the 
Define menu > Load Cases command to de-
fine gravity load cases (Dead and Live), then 
click More under load "Type" to access the 
Notional load option. Give the Notional load a 
descriptive name, click the Add Load button 
with default Auto in the Auto Lateral Load 
column, then click the Modify Lateral Load 
button, which generates this form.  

Users should define a notional load for each 
gravity load case in both X and Y lateral di-
rections and SAP2000 will then automatically 
generate notional lateral loads based on that 
specified proportion of the gravity load defini-
tions. The default is to generate 0.002 of the specified gravity load case as a notional lateral 
load case, but since SAP2000 versions prior to V11.07 are limited to Tau-b fixed, the code re-
quires generation of notional loads using a 0.003 load ratio, which means that users must 
change the default. Within the Analysis case definition, a negative multiplier subsequently 
can be assigned to account for plus and minus directions of the lateral loads. 

 Definition of Analysis Cases and Load combinations. P-delta analysis is nonlinear and 
must be completed at LRFD load levels. Since SAP2000 does not automatically generate load 
combinations for nonlinear cases, the way to create nonlinear combos is to use the Define 
menu > Analysis Cases command. Give the analysis case a name and select Nonlinear for the 
Analysis type. Then specify p-delta for a Geometric nonlinearity parameter as shown in the 
following form. As previously stated, SAP2000's p-delta analysis automatically accounts for 
both sway and local effects. Use the following form to define factored load combinations,  
including directional plus and minus factors.  
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After factored load combinations 
have been defined within the 
Analysis cases, next tell SAP2000 
that these analysis cases are com-
binations to be included in the de-
sign. Use the Define menu > Com-
binations command to define each 
load combination to have one 
Analysis case "combo".  For ex-
ample, in this screen capture, 
COMB1 is made up of 
DESIGNCOMB1 that was defined 
under Analysis cases. The combi-
nation was defined in the Analysis 
case definition because a nonlinear 
analysis was being run, and fac-
tored loads cannot be properly 
combined in a nonlinear analysis 
using linear algebraic summation. 
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After defining load combina-
tions, specify which load com-
binations are to be used by 
SAP2000 for design. Click the 
Design menu > Steel Fame De-
sign > Select Design Combos 
command. Remove any default 
load combos in the "Design 
combos" list and add the user- 
defined combination for the  
design. 

 

 

 

 Auto-mesh (optional) for crea-
tion of additional joints. Alt-
hough SAP2000 and ETABS au-
tomatically consider local p-delta 
effects, in some cases users may 
need to add an additional joint 
between the I and J joints of the 
frames in a model. Users can 
easily do this without dividing 
their frames into multiple seg-
ments by selecting columns only 
or by selecting the entire model 
and then the  Assign menu > 
Frame > Automatic Frame Mesh 
command. Use the "Minimum 
number of segments" options and 
type 2 in the edit box.  

SAP2000 and ETABS will internally add an intermediate joint on each selected frame ele-
ment for analysis, but reformulate the elements in the results so that they are reported and de-
signed as singular objects. We have had excellent correlation on AISC benchmarks without 
adding joints, but in a few cases it was necessary to add 1 intermediate joint to match perfect-
ly. In very large models, these additional auto-mesh joints may add to runtime, but in most 
structures the increased runtime will be negligible. 
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